Le son n'attend pas les images et ça s'aggrave ...

Questions / réponses pour le rippack uniquement !

Modérateur : Modérateurs

Répondre
michel
Apprenti
Apprenti
Messages : 38
Inscription : mar. mars 26, 2002 10:13 am

Le son n'attend pas les images et ça s'aggrave ...

Message par michel »

C'est nouveau, jamais rencontré le problème !
J'ai encodé avec Rippack 16.1 un film (Sur mes lèvres) et le son (divx) est légèrement en avance au début du film (~1seconde) et franchement à la fin (plusieurs secondes).
J'ai tenté un 2ème encodage de son en mp3, même résultat.
J'ai extrait le son avec AC3tool, encodé en mp3 en 44,1 et en 48.
J'ai ajouté la piste son au fichier avi (sans le son).
Avec chacune des 2 pistes 44.1 ou 48 j'ai toujours le son qui prend de l'avance de plus en plus.
Avec Virtualdub (interleaving) j'arrive à recaler au début mais en fin de film je retrouve un son en avance.
Qui a déjà eu ce problème?
Je ne veux pas mourir idiot et j'aimerais comprendre.
Merci pour toute aide.

Avatar de l’utilisateur
lauden
Sâge !
Sâge !
Messages : 1530
Inscription : jeu. févr. 21, 2002 12:00 am
Localisation : sud-est

Message par lauden »

Tu avais deux décalages :

1 décalage constant que tu as corrigé et 1 décalage progressif. Comme ton son est en avance sur l'image, il va falloir augmenter légèrement le framerate de ta vidéo.

michel
Apprenti
Apprenti
Messages : 38
Inscription : mar. mars 26, 2002 10:13 am

framerate ... ?

Message par michel »

Peux tu me détailler un peu plus le processus?
Attention si j'ai déja encodé de nombreux divx, je n'ai eu que très très rarement des problèmes alors mon expérience est assez limité.
Avec quel logiciel je peux changer le frame rate, virualdub? ou avec le lecteur? est ce possible avec bsplayer (c'est un peu mon chouchou).
Dans l'attente ... merci.

Avatar de l’utilisateur
Stryke
Expert
Expert
Messages : 81
Inscription : jeu. mars 13, 2003 6:28 pm

Message par Stryke »

Voir l'explication du maitre nexus :jap:

viewtopic.php?t=9006

michel
Apprenti
Apprenti
Messages : 38
Inscription : mar. mars 26, 2002 10:13 am

pour le MAITRE

Message par michel »

OUHAAA ça c'est un guide!!!
J'ai imprimmé les explications et j'essaye ça ce soir.
Merci

michel
Apprenti
Apprenti
Messages : 38
Inscription : mar. mars 26, 2002 10:13 am

pour Lauden & Stryke

Message par michel »

Pas mal d'essais hier soir avec les conseils du maître et mon problème reste inchangé.
Je pense que je n'ai pas de décalage au départ pas que celui-ci se cré dès le début du film et augmente sans cesse.
Je n'ai pas pu avec virtualdub refaire le son en 48 au mieu de 44.1, comme conseillé, j'obtiens un message d'erreur? Le film a été fait avec rippack 16.1 avec un son mp3. J'avais déja essayé avec une piste son extrait des vobs avec AC3tool de l'obtenir en 48, et de le recoler au fichier avi sans son, mais à l'arrivée même problème de décalage de son croissant.
Si Lauden peux m'en dire un peu plus sur sa méthode pour retoucher le framerate, je n'ai pas tous saisi...
Nota : il est surprenant que j'ai ce problème avec ce film, "sur mes lèvres" ou le personnage central lit sur les lèvres des autres, on voit donc souvent des acteurs joués et parlé en silence, puis une voix off nous donne la réplique ...
A l'aide, j'aimerais comprendre ce problème et pouvoir le résoudre.

Avatar de l’utilisateur
dou
Empereur
Empereur
Messages : 5003
Inscription : ven. mai 09, 2003 1:10 pm

Message par dou »

Tu fais avec nandub
Open file *.avi
video / frame rate et là tu peux ajuster à un framerate proposé ou calculer et ajuster toi-même.
video / direct stream copy (change pas la video)
file / save as toto.avi

De mémoire, ca gaze :wink:

jeru
Expert
Expert
Messages : 59
Inscription : ven. sept. 19, 2003 8:53 pm
Localisation : toulouse-agen

Message par jeru »

je peu dire une connerie?
moi quand j'avais un decalage il me suffisait de baisser la qualité du decodage et ca marchai. en fait c'etais maconfigu qui etais trop faible pour decoder la video en tres haute qualité :dehors2:

Avatar de l’utilisateur
lauden
Sâge !
Sâge !
Messages : 1530
Inscription : jeu. févr. 21, 2002 12:00 am
Localisation : sud-est

Re: pour Lauden & Stryke

Message par lauden »

michel a écrit :Si Lauden peux m'en dire un peu plus sur sa méthode pour retoucher le framerate, je n'ai pas tous saisi....
Normal je n'ai rien expliqué :)

Le framerate c'est le nombre d'images (frame) qui s'affichent en 1 seconde (fps). En PAL c'est 25, en NTSC c'est 29.97, au cinéma c'est 24, etc.
Dans ton cas le son prend progressivement de l'avance par rapport à la vidéo, c'est donc que tes images s'affichent trop lentement.
Pour corriger la difficulté est de quantifier la valeur du décalage à la fin du film. Sinon la méthode est simple.

Par exemple : Pour un film de 90 mn en PAL et un son en avance de 3 secondes.

la durée de ta bande son sera de (90 x 60) - 3 = 5397s
ton framerate devrait être de : 90 x 60 x25 = 135000 ÷ 5397 = 25,013...
C'est cette valeur qu'il faudra indiquer au soft qui te servira à faire la correction. N'hésite pas à refaire la manip en modifiant légèrement la nouvelle valeur du framerate, car il est rare d'arriver à bien corriger du 1er coup.

Perso j'utilise Ripp-it, mais il existe aussi AviInfo, Nandub, VirtualDub,...

A+

michel
Apprenti
Apprenti
Messages : 38
Inscription : mar. mars 26, 2002 10:13 am

suite

Message par michel »

merci pour vos conseils, je tente tout cela ce soir et je vous tiens au courant. 'désolé mais je n'ai pas de net ou se trouve mon pc pour les divx)

michel
Apprenti
Apprenti
Messages : 38
Inscription : mar. mars 26, 2002 10:13 am

pour Dou & Lauden

Message par michel »

Ca y est ça marche ... ouaiiis!
Voila comment j'ai procédé :
- j'ai utilisé Nandub pour recalculer avec un framerate à 25.000.
nota : j'avais noté que tous mes films réalisé avec Rippack étaient à 25.000 ou 24.999, celui-ci qui me posait problème était lui seul à 24,964 ????
Et là plus de décalage progressif !
Je n'ai pas compris pourquoi avec ce film j'ai eu ce problème. Depuis j'ai "Rippacké" plusieurs autres film et aucun problème. Aucun un mystère !
Merci à tous pour votre aide? C'était très sympa.

Répondre